VMware vSphere Web Client en español con la versión 6 Update 2

Esta semana VMware ha publicado nuevas versiones de varios de sus productos, entre ellos los componentes de vSphere.

Así que, como suele ser habitual, he procedido a actualizar mis servidores de laboratorio llevándome una sorpresa, ahora el interfaz web de vSphere está disponible en español. Era algo que no había leído en las Release Notes ni en los artículos publicados con la nueva versión.

El interfaz reconoce el idioma configurado en el navegador con el que accedemos y presenta el contenido en el interfaz correspondiente.

Como podéis ver en la siguiente imagen tenemos todo el interfaz en castellano (o casi)

VCSAU2-Error-004

Tengo que decir que me he encontrado un pequeño problema, ya que tras introducir el usuario y contraseña por primera vez, antes de que cargase todo el interfaz me ha aparecido la siguiente ventana de error:

VCSAU2-Error-001

"Se produjo un error interno: Unable to load resource module from /vsphere-client/vco-ui/locales/vco-ui-es_ES.swf"

Este error se produce porque no existe el archivo correspondiente a la traducción en español para el interfaz de administración de Orchestrator. Si pinchamos en No, podemos acceder y trabajar con normalidad, pero veremos este error cada vez que accedemos al cliente.

Para evitar este problema, tenemos, al menos, un par de opciones:

  • Si no utilizamos Orchestrator podemos deshabilitar el plugin y evitar que se carge en el interfaz web

VCSAU2-Error-005

  • Cambiar el idioma por defecto del navegador
  • Indicar en la URL de acceso a vSphere Web Client, el idioma que queremos utilizar, de la siguiente forma
https://<vcenter>/vsphere-client/?locale=xx_YY

Donde xx_YY puede tomar los valores:

  • English = en_US
  • German = de_DE
  • French = fr_FR
  • Spanish = es_ES
  • Japanese = ja_JP
  • Chinese = zh_CN
  • Korean = ko_KR

Lo ideal sería utilizar el interfaz en español sin este molesto error, pero de momento no he encontrado la forma de solucionarlo.

He intentado solucionar el problema a nivel de los archivos del vCenter, pero no he conseguido una solución, así que de momento, si queremos utilizar el cliente web en español, tendremos que soportar el mensaje de error al iniciar la sesión.

 

9 comentarios en «VMware vSphere Web Client en español con la versión 6 Update 2»

  • el 20 abril, 2016 a las 4:06 pm
    Enlace permanente

    Acababa de actualizar mi vCenter y he tenido el mismo problema.
    De momento lo he arreglado con la extensión de Google Chrome: Quick Language Switcher
    Muchas gracias por la información.

    Respuesta
    • el 1 mayo, 2016 a las 9:45 am
      Enlace permanente

      Hola José Ignacio,

      Gracias por compartir una solución a este problema. Yo sigo trabajando con el interfaz en inglés, porque con los años ya me he acostumbrado, pero para alguien que empieza y no está acostumbrado al inglés, le puede venir bien.

      Un saludo,

      Respuesta
  • el 22 abril, 2016 a las 9:09 am
    Enlace permanente

    Roberto
    Gracias por compartir.
    en mi caso da el mismo mensaje después que instalo Vshphere Replication. con un problema adicional que cuando quiero usar para configurar la replicación da un mensaje que no está disponible o no está configurado.

    Respuesta
    • el 1 mayo, 2016 a las 10:15 am
      Enlace permanente

      Hola Pedro,

      Si yo también tengo el mismo problema con Replication. Parece que la traducción todavía no está disponible para todas las soluciones del entorno vSphere y genera este tipo de errores. Como yo lo forzaba a que me funcionase en inglés (la costumbre, jeje) no me había fijado.

      Gracias por el comentario y un saludo,

      Respuesta
  • el 28 septiembre, 2016 a las 9:31 am
    Enlace permanente

    ¡Hola!
    Yo también tenía este problema y gracias a tu artículo he dejado de ver el molesto error, además de volver al inglés al que ya estaba más que acostumbrado pal venir de la versión 5.5 de vCenter

    Respuesta
  • el 30 octubre, 2016 a las 9:17 pm
    Enlace permanente

    Hola Roberto

    yo he probado otra opción que es la de duplicar el fichero monitoring-ui-en_US.swf y poner como que es el español monitoring-ui-es_ES.swf, y parece que de momento va bien y se ve el orchestator eso si en ingles pero el resto en castellano.

    La ruta donde estan los ficheros en mi vcenter6 en windows es esta:
    C:\Program Files\VMware\vCenter Server\WebClient\server\work\deployer\s\global\138\0\monitoring-ui-war-1.0.0.war\locales

    Saludos a Todos

    Respuesta
    • el 1 noviembre, 2016 a las 7:48 pm
      Enlace permanente

      Ligero problemilla con esta opción 🙂

      la ruta es un despliegue de la aplicación por lo que cada vez que reiniciamos el servidor Vcenter se volveria a generar y desaparece el fichero, habria que volverlo a colocar o lanzar un scritp al iniciar que haga la copia.

      Saludos

      Respuesta
      • el 20 noviembre, 2016 a las 6:13 pm
        Enlace permanente

        Gracias por el aporte. Fue uno de mis intentos de solucionar el problema en mi laboratorio, pero al ver que pasaba justo lo que comentas no lo puse. Puede que a alguien le sirva.

        Respuesta
  • el 30 mayo, 2018 a las 3:12 pm
    Enlace permanente

    Hola,

    Tenía el mismo error, lo soluciones agregando el soporte de inglés al Goolgle Chrome.

    Saludos,

    Respuesta

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.